Fault with trip computer / Wiper stalk unit

Discussion in 'Interior and Audio' started by tauhammerhead, Jul 17, 2016.

  1. tauhammerhead

    tauhammerhead Paid Member

    42
    Clio 197
    Hello!

    I'm new to the forum! I have an '08 197 clio RS (will hopefully post some pics here soon :thumbup:smile:.

    The buttons on the end of the wiper stalk seem to no longer work so I can't change display. I suspect this will also cause problems when I take it to get serviced and they won't be able to reset it. Has anybody else had this issue?

    I've seen a how-to for replacing the indicator stalk unit but not the other side. Is it straight forward for the other side and can I buy a used unit to fit in or is there some dodgy stuff with the wiring that means I need to buy it new?

    Best,

    Tauhammerhead
     

  2. Mattb_197

    Mattb_197

    336
    Lancashire
    Clio Sport 197
    There is a guide floating about on here somewhere that details how to remove them and take them to bits to clean the contacts, I'd try that first as they're not the cheapest of things to replace. I need to do both of mine really as the wiper stalk trip buttons sometimes don't work, the wipers sometimes have a funny do and if I've got the fog lights on sometimes indicating will turn them off lol. Good old French electronics!
     
  3. tauhammerhead

    tauhammerhead Paid Member

    42
    Clio 197
    Very delayed response and sorry admins for reviving this post but I thought it may be useful for future people!

    Wiper stalk was actually relatively straight forward to remove (just need to be careful to disconnect the wires around the unit before you yank too hard!).

    I tried out a couple of different second hand units before finding out that the wiper stalk was fine - the actual issue lay with the UCH which needed completely replacing! Had to take it into Renault and have a new one fitted and programmed for a total of £400 :shocked:
     
  4. Heppy997

    Heppy997 Paid Member

    94
    Huddersfield
    clio 197
    I have the exact same problem @tauhammerhead, the trip computer buttons don't work but the rest of the stalk does (wipers etc). I swapped out the stalk unit and no difference. Also checked the wiring from the stalk, all seems fine. Another suspect thing is the horn has stopped working too now, and I'm wondering if its related - the horn itself is fine, there is no voltage from the switch.

    Do you have any more info on the UCH? Can you fit a used one from a breakers? Don't fancy shelling 400 notes out for a button :tearsofjoy:
     
  5. tauhammerhead

    tauhammerhead Paid Member

    42
    Clio 197
    @Heppy997 - Sorry to hear that! From my understanding the UCH, like the ECU, is hard programmed to your car and cannot be easily reprogrammed (if at all) from another car. The Renault dealer actually scuppered the first one they installed and had to order another one at their expense!
    Unfortunately, unless someone else can recommend any other simple tests, I'd take it to a Renault garage and ask for the most experienced mechanic to diagnose the problem as it is quite unique. Worth mentioning to them what you have tried (replacing the stalk unit) as that will be the first thing they suggest or try (At your expense). Looking back at my invoices the UCH cost about £300 and labour was on top.
     

  • Share This Page