Help

Discussion in 'Clio 197 Area' started by Mick K-T, Apr 16, 2018.

  1. Mick K-T

    Mick K-T Paid Member

    Messages:
    34
    Location:
    Lancashire
    Car:
    Clio 197
    My clutch slave cylinder has gone on my 197. Lucky I was just pulling on my road when it went. Now I'm finding I can't even put the ignition on or start the car, was hoping to tow the car to the garage but with no power obviously steering and brakes are effected. Any suggestions. Central locking is working but that's it.
     

  2. Foxspeed

    Foxspeed "the new red baron" Moderator

    Messages:
    15,509
    Location:
    sat behind a laptop over-moderating...
    Car:
    ford mustang shadow gt v8
    should fire up & run even without the slave working - have made sure its out of gear?
     
  3. Pav

    Pav Moderator

    Messages:
    11,237
    Location:
    Manchester
    Car:
    albi blue 197 with boost
    still should be able to run it as above..must be something else..
     
  4. Mick K-T

    Mick K-T Paid Member

    Messages:
    34
    Location:
    Lancashire
    Car:
    Clio 197
    Manage to sort it, it had blown the main fuse just need to find a replacement
     
    Big Ben and Pav like this.
  5. Mick K-T

    Mick K-T Paid Member

    Messages:
    34
    Location:
    Lancashire
    Car:
    Clio 197
    Well finally I've got a my Clio back after having the slave cyclinder and clutch replaced can say what I massive difference it has made to the car.

    When I picked my car up the mechanic was giving the car a clean and I thought excellent great service. That was until this morning when I have gone to my car to find 3 small dents in the door and a puncture hole in the side skirt!! Gutted isn't the word I have emailed the pictures to the garage and hopefully will hear back Monday for an explanation
     

    Attached Files:

  6. Mick K-T

    Mick K-T Paid Member

    Messages:
    34
    Location:
    Lancashire
    Car:
    Clio 197
     

    Attached Files:

  7. Pav

    Pav Moderator

    Messages:
    11,237
    Location:
    Manchester
    Car:
    albi blue 197 with boost
    that is shocking..people should learn to appreciate somebody else's motors..i would be livid..hope they admit their fault and will make it right..
     
  8. Barney626

    Barney626 Winner - POTM December 2017

    Messages:
    527
    Location:
    Loughborough
    Car:
    Clio 197 - Nimbus
    That's pretty disgusting for people who call themselves professionals...
     
  9. Big Ben

    Big Ben Winner - POTM February 2018 Paid Member

    Messages:
    5,018
    Location:
    Herts
    Car:
    197
    That is appalling. Let us know what they say!
     
  10. Mick K-T

    Mick K-T Paid Member

    Messages:
    34
    Location:
    Lancashire
    Car:
    Clio 197
    Well the manager of the garage rang me up to apologize and have said they will have the car repaired but at a garage they use (ideally would have preferred my choice ) but at least it will be getting sorted.
     
    Beany likes this.
  11. Pav

    Pav Moderator

    Messages:
    11,237
    Location:
    Manchester
    Car:
    albi blue 197 with boost
    good news..glad they are making it right...
     

  • Share This Page


    1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
      By continuing to use this site, you are consenting to our use of cookies.